Студопедия
Случайная страница | ТОМ-1 | ТОМ-2 | ТОМ-3
АвтомобилиАстрономияБиологияГеографияДом и садДругие языкиДругоеИнформатика
ИсторияКультураЛитератураЛогикаМатематикаМедицинаМеталлургияМеханика
ОбразованиеОхрана трудаПедагогикаПолитикаПравоПсихологияРелигияРиторика
СоциологияСпортСтроительствоТехнологияТуризмФизикаФилософияФинансы
ХимияЧерчениеЭкологияЭкономикаЭлектроника

Методические рекомендации к заданию 3. КонецПроцедуры

Читайте также:
  1. II МЕТОДИЧЕСКИЕ РЕКОМЕНДАЦИИ ПО ПОДГОТОВКЕ К ПРАКТИЧЕСКОМУ ЗАНЯТИЮ
  2. II. МЕТОДИЧЕСКИЕ УКАЗАНИЯ ДЛЯ ВЫПОЛНЕНИЯ САМОСТОЯТЕЛЬНОЙ РАБОТЫ
  3. II. Методические указания по изучению дисциплины
  4. IV. Учебно-методические сборы.
  5. VI. МЕТОДИЧЕСКИЕ УКАЗАНИЯ ПО НАПИСАНИЮ РЕФЕРАТА (КОНТРОЛЬНОЙ РАБОТЫ)
  6. VII. МЕТОДИЧЕСКИЕ УКАЗАНИЯ ПО ПОДГОТОВКЕ КОНТРОЛЬНЫХ РАБОТ
  7. Выработаны ли в судебной практике рекомендации, в каких случаях суды не вправе устанавливать обеспечительные меры?
Помощь ✍️ в написании учебных работ
1500+ квалифицированных специалистов готовы вам помочь
Процедура Сформировать() ДБФ = СоздатьОбъект("XBase"); ДБФ.ДобавитьПоле("NAME", "S", 25,0); ДБФ.СоздатьФайл("c:\Test.dbf"); Спр = СоздатьОбъект("Справочник.Номенклатура"); Спр.ВыбратьЭлементы(); Пока Спр.ПолучитьЭлемент()>0 Цикл ДБФ.Добавить(); ДБФ.NAME=Спр.Наименование; ДБФ.Записать(); КонецЦикла; ДБФ.ЗакрытьФайл();

КонецПроцедуры

 

 


Задание на контрольную работу по дисциплине «Автоматизированные системы обработки коммерческой информации». Вариант 4

 

Задание 1.

 

Создайте новый документ. На форме этого документа должно быть 5 числовых полей.

При открытии документа:

При изменении значений первого, второго, третьего и четвертого полей:

 

Задание 2.

 

Создайте отчет, в котором будут следующим образом выводиться все активные, пассивные и активно-пассивные счета из вашего плана счетов:

 

Активные счета Пассивные счета Активно-пассивные счета
01 Основные средства 10 Материалы … 02 Амортизация ОС 05 Амортизация НМА … 40 Выпуск продукции 68 Налоги и сборы …

 

Задание 3.

 

1. Создайте файл 4.dbf. Этот файл должен содержать таблицу со следующими полями (названия полей придумайте самостоятельно):

· Название товара;

· Цена товара;

· Признак товара – импортный или отечественный;

· Страна-производитель товара;

· Дата изготовления товара.

Введите в таблицу 10 записей.

2. Создайте в Конфигураторе необходимый справочник «Товары». Форма элемента этого справочника должна состоять из нескольких слоев:

3. Создайте отчет, с помощью которого можно перенести все записи из файла 4.dbf в справочник «Товары».

 

 

Методические рекомендации к заданию 3.

Процедура Сформировать() ДБФ = СоздатьОбъект("XBase"); ДБФ.ДобавитьПоле("NAME", "S", 25,0); ДБФ.СоздатьФайл("c:\Test.dbf"); Спр = СоздатьОбъект("Справочник.Номенклатура"); Спр.ВыбратьЭлементы(); Пока Спр.ПолучитьЭлемент()>0 Цикл ДБФ.Добавить(); ДБФ.NAME=Спр.Наименование; ДБФ.Записать(); КонецЦикла; ДБФ.ЗакрытьФайл();

КонецПроцедуры


Задание на контрольную работу по дисциплине «Автоматизированные системы обработки коммерческой информации». Вариант 5

 

Задание 1.

 

Создайте новый документ. На форме этого документа должно быть 5 числовых полей.

При открытии документа:

При изменении значений первого, второго и третьего полей:

 

 

Задание 2.

 

Создайте отчет, в котором будут следующим образом выводиться все балансовые и забалансовые счета из вашего плана счетов:

 

Балансовые счета Забалансовые счета
01 Основные средства 02 Амортизация ОС … 001 Арендованные ОС 002 ТМЦ на отв. хранении …

 

Задание 3.

 

1. Создайте файл 5.dbf. Этот файл должен содержать таблицу со следующими полями (названия полей придумайте самостоятельно):

· Название продукции;

· Себестоимость продукции;

· Наценка (в процентах);

· Номер цеха или отдела, в котором продукция производилась;

· Дата изготовления продукции.

Введите в таблицу 10 записей.

2. Создайте в Конфигураторе необходимый справочник «Продукция». Форма элемента этого справочника должна состоять из нескольких слоев:

3. Создайте отчет, с помощью которого можно перенести все записи из файла 5.dbf в справочник «Продукция».

 

 

Доверь свою работу ✍️ кандидату наук!
1500+ квалифицированных специалистов готовы вам помочь

Дата добавления: 2015-07-08; просмотров: 113 | Нарушение авторских прав


 

 

<== предыдущая страница | следующая страница ==>
Методические рекомендации к заданию 3.| Коренной текст.

mybiblioteka.su - 2015-2022 год. (0.056 сек.)