Студопедия
Случайная страница | ТОМ-1 | ТОМ-2 | ТОМ-3
АвтомобилиАстрономияБиологияГеографияДом и садДругие языкиДругоеИнформатика
ИсторияКультураЛитератураЛогикаМатематикаМедицинаМеталлургияМеханика
ОбразованиеОхрана трудаПедагогикаПолитикаПравоПсихологияРелигияРиторика
СоциологияСпортСтроительствоТехнологияТуризмФизикаФилософияФинансы
ХимияЧерчениеЭкологияЭкономикаЭлектроника

Методические рекомендации к заданию 3.

Читайте также:
  1. II МЕТОДИЧЕСКИЕ РЕКОМЕНДАЦИИ ПО ПОДГОТОВКЕ К ПРАКТИЧЕСКОМУ ЗАНЯТИЮ
  2. II. МЕТОДИЧЕСКИЕ УКАЗАНИЯ ДЛЯ ВЫПОЛНЕНИЯ САМОСТОЯТЕЛЬНОЙ РАБОТЫ
  3. II. Методические указания по изучению дисциплины
  4. IV. Учебно-методические сборы.
  5. VI. МЕТОДИЧЕСКИЕ УКАЗАНИЯ ПО НАПИСАНИЮ РЕФЕРАТА (КОНТРОЛЬНОЙ РАБОТЫ)
  6. VII. МЕТОДИЧЕСКИЕ УКАЗАНИЯ ПО ПОДГОТОВКЕ КОНТРОЛЬНЫХ РАБОТ
  7. Выработаны ли в судебной практике рекомендации, в каких случаях суды не вправе устанавливать обеспечительные меры?

Задание на контрольную работу по дисциплине «Автоматизированные системы обработки коммерческой информации». Вариант 1

Задание 1.

 

Создайте новый документ. На форме этого документа должно быть 4 числовых поля.

При открытии документа:

При изменении значений первого, второго и третьего полей:

 

 

Задание 2.

 

Создайте отчет, в котором все элементы справочника ОсновныеСредства будут выводиться в следующей таблице:

Основные средства со стоимостью до 1000 рублей Основные средства со стоимостью от 1000 до 5000 рублей Основные средства со стоимостью свыше 5000 рублей

 

Задание 3.

 

1. Создайте файл 1.dbf. Этот файл должен содержать таблицу со следующими полями (названия полей придумайте самостоятельно):

· Название материала;

· Единица измерения;

· Дата поступления материалов;

· Цена за 1;

· Название фирмы-поставщика.

Введите в таблицу 10 записей.

2. Создайте в Конфигураторе необходимый справочник «Материалы». Форма элемента этого справочника должна состоять из нескольких слоев:

Введите в справочник несколько новых записей.

3. Создайте отчет, с помощью которого можно перенести все записи из файла 1.dbf в справочник «Материалы».

 

 

Методические рекомендации к заданию 3.

Процедура Сформировать() ДБФ = СоздатьОбъект("XBase"); ДБФ.ДобавитьПоле("NAME", "S", 25,0); ДБФ.СоздатьФайл("c:\Test.dbf"); Спр = СоздатьОбъект("Справочник.Номенклатура"); Спр.ВыбратьЭлементы(); Пока Спр.ПолучитьЭлемент()>0 Цикл ДБФ.Добавить(); ДБФ.NAME=Спр.Наименование; ДБФ.Записать(); КонецЦикла; ДБФ.ЗакрытьФайл();

КонецПроцедуры

 


Задание на контрольную работу по дисциплине «Автоматизированные системы обработки коммерческой информации». Вариант 2

 

Задание 1.

 

Создайте новый документ. На форме этого документа должно быть 2 числовых поля.

При открытии документа:

При изменении значения первого поля:

 

 

Задание 2.

 

Создайте отчет, в котором ВСЕ счета из ВАШЕГО плана счетов будут выводиться в следующей таблице:

 

Активные балансовые счета Пассивные балансовые счета Активно-пассивные балансовые счета Активные забалансовые счета Пассивные забалансовые счета Активно-пассивные забалансовые счета

 



 

Задание 3.

 

1. Создайте файл 2.dbf. Этот файл должен содержать таблицу со следующими полями (названия полей придумайте самостоятельно):

· Название нематериального актива;

· Контрагент;

· Время действия НМА;

· Цена;

· Дата поступления НМА.

Введите в таблицу 10 записей.

2. Создайте в Конфигураторе необходимый справочник «НМА». Форма элемента этого справочника должна состоять из нескольких слоев:

3. Создайте отчет, с помощью которого можно перенести все записи из файла 2.dbf в справочник «НМА».

 

 

Методические рекомендации к заданию 3.

Процедура Сформировать() ДБФ = СоздатьОбъект("XBase"); ДБФ.ДобавитьПоле("NAME", "S", 25,0); ДБФ.СоздатьФайл("c:\Test.dbf"); Спр = СоздатьОбъект("Справочник.Номенклатура"); Спр.ВыбратьЭлементы(); Пока Спр.ПолучитьЭлемент()>0 Цикл ДБФ.Добавить(); ДБФ.NAME=Спр.Наименование; ДБФ.Записать(); КонецЦикла; ДБФ.ЗакрытьФайл();

КонецПроцедуры

Загрузка...

 


Задание на контрольную работу по дисциплине «Автоматизированные системы обработки коммерческой информации». Вариант 3

 

Задание 1.

 

Создайте новый документ. На форме этого документа должно быть 3 числовых поля.

При открытии документа:

При изменении значений первого и второго полей:

 

 

Задание 2.

 

Создайте отчет, в котором будут следующим образом выводиться счета из вашего плана счетов, на которых ведется количественный учет и на которых не ведется:

 

Ведется количественный учет Не ведется количественный учет
10 Материалы 41 Товары … 01 Основные средства 02 Амортизация ОС …

 

Задание 3.

1. Создайте файл 3.dbf. Этот файл должен содержать таблицу со следующими полями (названия полей придумайте самостоятельно):

· Название фирмы-поставщика;

· Юридический адрес фирмы-поставщика;

· Дата учреждения фирмы-поставщика;

· Количество лет сотрудничества;

· ФИО руководителя фирмы-поставщика.

Введите в таблицу 10 записей.

2. Создайте в Конфигураторе необходимый справочник «Поставщики». Форма элемента этого справочника должна состоять из нескольких слоев:

3. Создайте отчет, с помощью которого можно перенести все записи из файла 3.dbf в справочник «Поставщики».

 

 


Дата добавления: 2015-07-08; просмотров: 112 | Нарушение авторских прав


<== предыдущая страница | следующая страница ==>
МИР входящему| Методические рекомендации к заданию 3.

mybiblioteka.su - 2015-2021 год. (0.01 сек.)